【メモ】Mavericksに更新したらHomebrewが

Mavericksにアップグレードしてからbrew upgradeを実行すると以下の様なWarningが出るようにばった。

Warning: No developer tools installed.
You should install the Command Line Tools.
Run `xcode-select –install` to install them.

OSをアップグレードしたことでCommand Line Toolsをインストールしなおさないとといけないらしい。

Xcodeから直接インストールはできないので、Downloads for Apple DevelopersからCommand Line Tools(OS X Mavericks)をダウンロード、インストールする。

そしてbrew update→upgradeすると今度はstdc++に関するエラーが出た。
もう面倒なのでHomebrewを再インストールすることに。

ココを参考に
rm -rf /usr/local/Cellar /usr/local/.git && brew cleanup
ruby -e “$(curl -fsSL https://raw.github.com/mxcl/homebrew/go)”
brew prune
としたが、
途中で
error: unable to unlink old ‘Library/(略)’ (Permission denied)
とのエラーが発生。
sudo chown -R ${USER} /usr/local/Library
とすることでディレクトリ内のファイルの所有者を変更してやり、完了した。

カテゴリー: OS X パーマリンク

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です